Access Keys:
Skip to content (Access Key - 0)

Kobold2D™

The All-In-One, Ready-To-Go development solution for cocos2d-iphone developers. Open source, ARC enabled, for iOS & Mac OS.

There's something even better than Kobold2D!
Check out KoboldTouch - it's Kobold2D with an MVC Framework, better Tilemap renderer, user support and a lot more.
Want to know what Kobold2D is about?
Learn what Kobold2D has to offer over "pure" cocos2d-iphone.
Kobold2D Compatibility Notes
  • Kobold2D is compatible with Xcode 4.5 or newer and AppCode 1.5 or newer. Older Xcode versions (4.2, 4.3, 4.4) may still work but are untested/unsupported.
  • Compatible with Mac OS X 10.7 Lion, Mac OS X 10.8 Mountain Lion, and iOS 6.
  • Using Kobold2D with Apple Beta (Preview) software like Xcode, iOS, Mac OS is strongly discouraged. Kobold2D is only tested with final versions of Xcode, iOS and Mac OS. We don't issue compatibility updates and can't offer support for issues with Apple Beta software.

Kobold2D v2.1.0

Uses cocos2d-iphone v2.1 and OpenGL ES 2.0. Minimum Deployment Target is iOS 5.0 / Mac OS X 10.7. Compatible with: iPhone 3GS and newer, iPod Touch 3rd generation and newer, all iPad models.

Kobold2D v2.0.4

Uses cocos2d-iphone v2.0 and OpenGL ES 2.0. Minimum Deployment Target is iOS 4.3 / Mac OS X 10.6. Compatible with: iPhone 3GS and newer, iPod Touch 3rd generation and newer, all iPad models.

Download Kobold2D v2.1.0

Download Kobold2D v2.0.4

Older Versions

These versions are no longer supported or updated.

Kobold2D v1.1.3

Uses cocos2d-iphone v1.1 and OpenGL ES 1.1. Minimum Deployment Target is iOS 4.0.
Compatible with: iPhone 3G and newer, iPod Touch 2nd generation and newer, all iPad models.

Download from Learn-Cocos2D.com

Kobold2D v1.0.5

Use this version if you're experiencing animation issues.

Uses cocos2d-iphone v1.0.1 and OpenGL ES 1.1. Minimum Deployment Target is iOS 3.1 (iOS 4.0 is recommended). Compatible with all iOS devices.

Download from Kobold2D.com

Kobold2D Release Notes

Kobold2D v2.1.0 Release Notes
The Most Important Changes & Additions
  • compatible with Xcode 4.6 (fixed FIX_CATEGORY_BUG issue and others)
  • improved App delegate to properly support iOS 6 autorotation
Minor Improvements & Bug Fixes
  • enabled armv7s architecture (iPhone 5, iPod touch 5, iPad 3/4) in all targets
Libraries updated
  • updated: cocos2d-iphone 2.1 rc0a
  • updated: cocos2d-iphone-extensions 0.21 (latest from github)
  • updated: Chipmunk 6.1.2
  • updated: Chipmunk Spacemanager 0.2.01
  • fixed: SneakyInput compiles with 2.1
  • fixed: Chipmunk Spacemanager compiles with 2.1 (setOpacity & setColor without function)
  • removed: AdMob SDK
Known Issues
  • Chipmunk SpaceManager is not fully compatible with cocos2d 2.1 (color and opacity changes may not be applied to sprites etc handled by SpaceManager)

All Release Notes

Level Up!

The Learn Cocos2D Book

Line-Drawing Game Starterkit

Excellent template code for creating your own Line-Drawing game, similar to popular titles such as Flight Control, Harbor Master, and Pirate Bay.

The iPhone RPG Engine

Rapidly create your own RPG or action-adventure game with this complete starter kit. Includes an ebook, game source code and a royalty-free art package.

Adaptavist Theme Builder Powered by Atlassian Confluence